If you have Update Rollup 2 for Windows XP Media Center Edition 2005 installed and you attempt to to download a version of Internet Explorer 7 whose language setting matches the language setting of your Windows XP Media Center Edition 2005, you receive a language compatibility error message and you cannot install Internet Explorer 7.

This behavior occurs because the Internet Explorer 7 version must match the base language of your computer's operating system, which is English for Windows XP Media Center Edition 2005.

NOTE: Windows XP Media Center Edition 2005 is localized by using the MUI (Multilingual User Interface) Pack.

To workaround this issue, install an English version of Internet Explorer 7.

To resolve this problem, use the Internet Explorer 7 MUI Pack, which will be available when the last fully localized version of Internet Explorer 7 is released in January 2007.