Microsoft recently caused quite a stir when it decided to stop giving new MSCEs a 1-year subscription to TechEd. Given the heat surrounding the topic, I wanted to consider just how important certification is for Windows NT Server 4.0, Terminal Services Edition (TSE) administrators, and how Microsoft and Citrix are addressing the issue. When it comes to server-based computing, what do the letters following your name say about your knowledge of terminal services?

For MCSE certification, the answer now and for the immediate future is, "not much." The Windows NT 4.0 MCSE exams do not and will not cover terminal services. Terminal services are currently a "niche technology," as Ann Marie McSweeny, program manager for Microsoft’s certification development, explained when we spoke last week. Reasonable. Because most companies have not deployed terminal services, it’s unfair to test NT administrators about information that they’re probably not using. For the same reason, Microsoft won't include terminal services as part of the initial Windows 2000 (Win2K) certification track, either, except in terms of installation and configuration of services. After issuing the initial Win2K exam, Microsoft will look at how heavily its customers are deploying terminal services and determine whether to add the technology to one of the core exams or whether this technology deserves a separate exam—perhaps as an elective on the MCSE track.

The lack of focus on terminal services isn’t a problem in itself. Terminal services isn’t Microsoft’s main focus right now and it never will be. The larger problem lies in how the certifications expire. Microsoft will retire the NT 4.0 exams on December 31, 2000, and will require MCSEs to pass the Win2K exam by December 31, 2001, to retain certification. What about those who aren’t yet using Win2K, or who aren’t planning to upgrade right away? McSweeney explained that Microsoft has structured the exams around the technology the company expects people to use, but requiring NT 4.0 MCSEs to upgrade to Win2K to remain certified seems a bit pushy. Unless you want to be a paper MCSE, rendered clueless by problems your classroom curriculum didn’t cover, you need hands-on experience with the products you’re certified in—which means you’ll have to upgrade to Win2K by 2002 whether you need the new OS or not.

I prefer the Citrix model of certification because it demonstrates that its holders are competent in a specific version of the software and it doesn’t require an upgrade. You’re a Citrix Certified Administrator (CCA) for MetaFrame 1.8 or 1.0, not for MetaFrame in general. Citrix offers an advanced topics certification that goes into more depth than the basic CCA, and, according to Bill Brown, director of educational services for Citrix, the company is working on a new track that will be more like the MCSE in that it will include tests dealing with technology issues such as security, remote management, and load balancing. But the per-product certifications aren’t going away. (Citrix is also considering Web-based training for a couple of its topics, but Brown would only say that a couple of subjects would be available in the first quarter of 2000.)

Which model says more about what you actually know: a model that encourages you to push for the latest certification regardless of your experience with the product, or a model that says you know how to use a certain version of the software and are familiar with helper tools that don’t change from version to version?