NOTE: See How to obtain and use the MS04-028 Enterprise Update Scanning Tool in environments that use Systems Management Server?

Microsoft Knowledge Base Article 886988 contains the following summary:

Microsoft has re-released the MS04-028 Enterprise Update Scanning Tool (MS04-028-EnterpriseScan-886988-x86-EN-v2.exe). IT professionals can use the MS04-028-EnterpriseScan-886988-x86-EN-v2.exe tool to scan computers for the required MS04-028 security updates and to apply any missing updates from a local area network (LAN) share. The tool can be run from a startup or logon script or by a user with local administrator rights. The tool is intended for use in environments where Microsoft Systems Management Server (SMS) or any other enterprise management solution is not used for update management. For SMS users, see the following Microsoft Knowledge Base article:
885920 How to obtain and use the MS04-028 Enterprise Update Scanning Tool in environments that use Systems Management Server 2003 and Systems Management Server 2.0
Notes

The MS04-028 Enterprise Update Scanning Tool has been tested on the operating systems that are listed in the Applies To section. See the MS04-028 security bulletin for a list of all affected products and components.

The revised version of the MS04-028 Enterprise Update Scanning Tool includes detection and deployment for Microsoft Visual FoxPro 8.0, as well as updates for Microsoft .NET Framework 1.0 with Service Pack 2 (SP2) and Microsoft .NET Framework 1.1.

The previous release of the MS04-028 Enterprise Update Scanning Tool included only security updatesfor the Microsoft .NET Framework products listed in the "Affected Software" section of the MS04-028 security bulletin . The updated version of this tool only checks for Microsoft .NET Framework 1.0 SP2 and Microsoft .NET Framework 1.1 updates for for each product listed in the "Affected Software" section of the MS04-028 security bulletin when checking for the Microsoft .NET Framework products that need updating . Customers who are using the previous version of this tool and who need security update detection, installation, or both can continue to use the original release of this tool and use the new version of this tool for Microsoft Visual FoxPro 8.0 detection . Microsoft recommends that customers who are using this tool for the first time use only the new version of this tool because it supports Microsoft .NET Framework 1.0 SP2 and Microsoft .NET Framework 1.1 updates.