SMS 2.0 requires that Windows NT 4.0, Service Pack 4 or later be installed.

Microsoft included the 40-bit version of SP4 on the SMS CD-ROM, and named the folder Nt4sp4a. They also have an option on the SMS setup screen entitled Install NT 4.0 SP4a and the release notes refer to Service Pack 4a for Windows NT Server 4.0.

No, you didn't miss a Service Pack release.

This is a clerical error, probabled caused by confusion between Windows NT 4.0 Service Pack 4 and Internet Explorer 4.01 Service Pack 1a, which is also included on the SMS CD-ROM.