Microsoft Knowledge Base Article 886988 contains the following summary and introduction:

SUMMARY

Microsoft has re-released the MS04-028 Enterprise Update Scanning Tool (MS04-028-EnterpriseScan-886988-x86-EN-v2.exe). IT professionals can use the MS04-028-EnterpriseScan-886988-x86-EN-v2.exe tool to scan computers for the required MS04-028 security updates and to apply any missing updates from a local area network (LAN) share. The tool can be run from a startup or logon script or by a user with local administrator rights. The tool is intended for use in environments where Microsoft Systems Management Server (SMS) or any other enterprise management solution is not used for update management. For SMS users, see the following Microsoft Knowledge Base article:

885920 How to obtain and use the MS04-028 Enterprise Update Scanning Tool in environments that use Systems Management Server 2003 and Systems Management Server 2.0

Notes

The MS04-028 Enterprise Update Scanning Tool has been tested on the operating systems that are listed in the Applies To section. See the MS04-028 security bulletin for a list of all affected products and components.

The revised version of the MS04-028 Enterprise Update Scanning Tool includes detection and deployment for Microsoft Visual FoxPro 8.0, as well as updates for Microsoft .NET Framework 1.0 with Service Pack 2 (SP2) and Microsoft .NET Framework 1.1.

The previous release of the MS04-028 Enterprise Update Scanning Tool included only security updatesfor the Microsoft .NET Framework products listed in the "Affected Software" section of the MS04-028 security bulletin. The updated version of this tool only checks for Microsoft .NET Framework 1.0 SP2 and Microsoft .NET Framework 1.1 updates for for each product listed in the "Affected Software" section of the MS04-028 security bulletin when checking for the Microsoft .NET Framework products that need updating. Customers who are using the previous version of this tool and who need security update detection, installation, or both can continue to use the original release of this tool and use the new version of this tool for Microsoft Visual FoxPro 8.0 detection. Microsoft recommends that customers who are using this tool for the first time use only the new version of this tool because it supports Microsoft .NET Framework 1.0 SP2 and Microsoft .NET Framework 1.1 updates.

For more information about Critical Security Update MS04-028, visit the following Microsoft Web site:

http://www.microsoft.com/technet/security/bulletin/MS04-028.mspx

The MS04-028 Enterprise Update Scanning Tool will detect and update the MS04-028 security updates for the following products:

•       Microsoft Windows XP, Windows XP Service Pack 1 (SP1)
Languages: English (United States), French (France), German (Germany), Japanese, Chinese (Taiwan), Chinese (China), Italian (Italy), Spanish (Spain), Korean
•       Microsoft Windows Server 2003
Languages: English (United States), French (France), German (Germany), Japanese, Chinese (Taiwan), Chinese (China), Italian (Italy), Spanish (Spain), Korean
•       Microsoft Office XP Service Pack 3 (SP3)
Languages: all supported languages
•       Microsoft Outlook 2002 SP3, Microsoft Word 2002 SP3, Microsoft Excel 2002 SP3, Microsoft PowerPoint 2002 SP3, Microsoft FrontPage 2002 SP3, Microsoft Publisher 2002 SP3, Microsoft Access 2002 SP3
Languages: all supported languages
•       Microsoft Office 2003
Languages: all supported languages
•       Office Outlook 2003, Office Word 2003, Office Excel 2003, Office PowerPoint 2003, Office FrontPage 2003, Office Publisher 2003, Office Access 2003, Microsoft Office InfoPath 2003, Microsoft Office OneNote 2003
Languages: all supported languages
•       Microsoft Project 2002 Service Pack 1 (SP1)
Languages: all supported languages
•       Microsoft Project 2003
Languages: all supported languages
•       Microsoft Visio 2002 Service Pack 2 (SP2)
Languages: all supported languages
•       Microsoft Visio 2003
Languages: all supported languages
•       Microsoft Visual Basic .NET Standard 2002, Microsoft Visual C# .NET Standard 2002, Microsoft Visual C++ .NET Standard 2002
Languages: all supported languages
•       Microsoft Visual Studio .NET 2002
Languages: all supported languages
•       Microsoft Visual Studio .NET 2003
Languages: all supported languages
•       Visual Basic .NET Standard 2003, Visual C# .NET Standard 2003, Visual C++ .NET Standard 2003, Visual J# .NET Standard 2003
Languages: all supported languages
•       Microsoft .NET Framework version 1.0 SDK Service Pack 2 (SP2)
•       Microsoft .NET Framework 1.0 with Service Pack 2 (SP2)
Languages: English (United States), French (France), German (Germany), Japanese, Chinese (Taiwan), Chinese (China), Italian (Italy), Spanish (Spain), Korean
•       Microsoft .NET Framework 1.1
Languages: all supported languages
•       Microsoft Picture It! 2002
Languages: English (United States), French (France), German (Germany), Japanese, Italian (Italy), Spanish (Spain)
•       Microsoft Greetings 2002
Languages: English (United States), French (France), German (Germany), Japanese, Italian (Italy), Spanish (Spain)
•       Microsoft Picture It! Version 7 and Microsoft Digital Image Pro version 7
Languages: English (United States), French (France), German (Germany), Japanese, Italian (Italy), Spanish (Spain), Korean
•       Microsoft Picture It! Version 9, Microsoft Digital Image Pro Version 9, Microsoft digital Image Suite Version 9
Languages: English (United States), French (France), German (Germany), Japanese, Italian (Italy), Spanish (Spain), Korean
•       Microsoft Producer for Microsoft Office PowerPoint
Languages: English (United States), French (France), German (Germany), Japanese, Chinese (Taiwan), Chinese (China), Italian (Italy), Spanish (Spain), Korean
•       Internet Explorer 6 Service Pack 1 (SP1)
Languages: English (United States), French (France), German (Germany), Japanese, Chinese (Taiwan), Chinese (China), Italian (Italy), Spanish (Spain), Korean
•       Windows Journal Viewer 1.5
Languages: Chinese (Taiwan), German (Germany), English (United States), French (France), Japanese, Korean, Chinese (China)
•       Microsoft Visual FoxPro 8.0
Languages: all supported languages
The MS04-028 Enterprise Update Scanning Tool will not detect or install the MS04-028 security updates for the following products:
•       The Platform SDK Redistributable
•       Microsoft Visual FoxPro 8.0 Runtime Library
The MS04-028 Enterprise Update Scanning Tool will not detect or install the MS04-028 security updates on the following operating systems:
•       Windows 98, Windows 98 SE, and Windows Millennium Edition
•       Windows NT 4.0 Workstation
•       Windows XP, 64-bit Editions
•       Windows Server 2003, 64-bit Editions
•       Windows XP Embedded

INTRODUCTION

This article contains step-by-step instructions on how to obtain the MS04-028 Scan and Update Tool and how to use the tool by using a startup script, a logon script, or by running the tool manually. This tool is intended to provide a scanning and deployment solution for the updates that are released with MS04-028 in environments where SMS or any other enterprise management solution is not used for update management. The steps are provided as an example only. You may have to modify the steps according to the requirements and the limitations of your environment.

The MS04-028 Enterprise Update Scanning Tool, version 2, has Microsoft .NET Framework 1.0 SP2 security update detection, Microsoft .NET Framework 1.1 security update detection, and Microsoft Visual FoxPro 8.0 detection .

The following files are available for download from the Microsoft Download Center:

MS04-028 Enterprise Update Scanning Tool, version 2:

DownloadDownload the MS04-028 Enterprise Update Scanning Tool, version 2 package now.

MS04-028 Enterprise Update Scanning Tool, version 1:

DownloadDownload the original MS04-028 Enterprise Update Scanning Tool package now.

Note The previous release of the MS04-028 Enterprise Update Scanning Tool included only service packs for the Microsoft .NET Framework products listed in the "Affected Software" section of the MS04-028 security bulletin. The updated version of this tool only checks for Microsoft .NET Framework 1.0 SP2 and Microsoft .NET Framework 1.0 updates for for each product listed in the "Affected Software" section of the MS04-028 security bulletin when checking for the Microsoft .NET Framework products that need updating. Customers who are using the previous version of this tool and who need service pack detection, installation, or both can continue to use the original release of this tool and use the new version of this tool for Microsoft Visual FoxPro 8.0 detection. Microsoft recommends that customers who are using this tool for the first time use only the new version of this tool because it supports Microsoft .NET Framework 1.0 SP2 and Microsoft .NET Framework 1.0 updates.