If you used Active Setup, look at the Active Setup log.txt file:

                                 Logging information for IE4Setup.exe ...                                 Checking for IE4 version.                                 File Version :C:\%SystemRoot%\System32\SHELL32.DLL: Version:4.0.1381.32772                                 File Version :C:\%SystemRoot%\System32\shdocvw.dll: Version:0.0.0.0                                 Version of ActiveX files.                                 File Version :C:\%SystemRoot%\System32\wininet.dll: Version:4.70.0.1215                                 File Version :C:\%SystemRoot%\System32\urlmon.dll: Version:4.70.0.1215                                 File Version :C:\%SystemRoot%\System32\shdocvw.dll: Version:0.0.0.0                                 File Version :C:\%SystemRoot%\System32\shlwapi.dll: Version:0.0.0.0                                 Version of trust files.                                 File Version :C:\%SystemRoot%\System32\Wintrust.dll: Version:4.75.1381.32772                                 File Version :C:\%SystemRoot%\System32\digsig.dll: Version:4.73.1381.40                                 File Version :C:\%SystemRoot%\System32\INSENG.DLL: Version:4.72.3110.6                                 File Version :C:\%SystemRoot%\System32\JOBEXEC.DLL: Version:4.72.3110.7
Delete all above DLLs except Shell32.dll.

Navigate to:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup

and delete the Active Setup key.

If %SystemRoot%\System32\Oleaut32.dll is missing, expand it from your NT CD:

Expand <CD-ROM:>\i386\Oleaut32.dl_ %SystemRoot%\System32\Oleaut32.dll

Delete the Active Setup log.txt file.

Rerun setup.