Does Microsoft Volume Shadow Copy Service (VSS) require Windows Server 2003, Enterprise Edition and Exchange Server 2003, Enterprise Edition?

Surprisingly, no. Windows 2003, Standard Edition and Exchange 2003, Standard Edition both support VSS. However, one key feature—the ability to take a point-in-time copy and use hardware volume transport to move that copy to another LUN on a Storage Area Network (SAN)—is available only in Windows 2003, Enterprise Edition. The bigger question isn't whether you can run VSS on standard edition servers but which VSS requestor you can use. Not all backup vendors have announced support for VSS, and not all the vendors who have announced support have implemented it.