And I thought it was just me: It seems the initial release of Navigator 4.02 contains a Java bug that brings up a dialog box stating that "system classes are not signed" and fails to run Java applets or the Netcaster itself, which is entirely written in Java. I run a lot of beta programs on my computer, so I assumed that had something to do with it but, actually, Netscape is to blame.

Today, Netscape product manager Dan Claussen confirmed that the version of the stand-alone Navigator that was posted to Netscape's site lacked the certificates necessary for Java to run properly. They have since replaced it with a newer version that fixes the bug. If you downloaded Navigator the first day it was available, you'll need to get it again. Unfortunately, Netscape has decided not to change the version number, so the only way to know whether yours is broke is to try and run Netcaster. If it fails, you need the new version