\[Editor's Note: Share your Exchange and Outlook discoveries, comments, problems, solutions, and experiences with products. Email your contributions (500 words or less) to r2rxadmin@winnetmag.com. We edit submissions for style, grammar, and length. If we print your submission, you'll get $100.\]

Several months ago, I used the Move Mailbox approach to upgrade my organization from Exchange Server 5.5 to Exchange 2000 Server Service Pack 2 (SP2) on a Windows 2000 Server SP3 system. After the Exchange migration, I followed the steps in the Microsoft articles "XADM: How to Remove the First Exchange Server in a Site" (http://support.microsoft.com/?kbid=152959) and "XADM: How to Remove the Last Exchange Server 5.5 Computer from an Exchange 2000 Administrative Group" (http://support.microsoft.com/?kbid=284148) to remove the Exchange 5.5 server, but I kept the mixed mode in case we needed to revert to Exchange 5.5.

Recently, our old Exchange 5.5 server was down for several weeks. I decided to make the best of this down time and switch the environment to native mode while the server was unavailable. I planned to install the newly released SP3 for Exchange 2000 at the same time.

I went into the office on a Saturday to accomplish these tasks. Friday night's backup was successful, so I proceeded with the installations. I followed the Exchange 2000 Service Pack 3 Deployment Guide to install Exchange 2000 SP3 and received no errors. Then, I switched the Exchange 2000 server to native mode and rebooted it. I was able to send and receive messages, and the event logs contained no errors.

On Monday morning, I checked the event log and found error 9175 The MAPI call "Open MsgStore" failed with the following error: The information store could not be opened. The login to the Microsoft Exchange Server failed. MAPI 1.0 ID no: 80040111-0286-0000 0000. I searched Microsoft's Web site but couldn't find any information about this error. The error continued to appear in the log file every morning when Exchange would have created the Offline Address Book (OAB).

That Saturday, the Mailbox Manager (which runs every Saturday morning) also generated error 9175, as well as error 9200 Failed to perform MAPI Logon. These errors repeated every time I tried to manually run the Mailbox Manager or generate the OAB.

I finally found the Microsoft article "XADM: Your Attempt to Generate an Offline Address List Does Not Work and Event 9126 Occurs" (http://support.microsoft.com/?kbid=315250), which at the time applied only to Exchange 5.5 servers. I checked the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\Exchange Provider registry subkey's DS Server entry and discovered that one of the Global Catalog (GC) servers was listed under DS Server. I deleted the entry, then I was able to generate the OAB. However, the Mailbox Manager still generated errors 9175 and 9200. I rebooted the server and noticed that a few minutes later the registry entry I had deleted reappeared. I needed to figure out what process or service was creating the DS Server registry entry.

The Exchange 2000 server was a dedicated server, running only Symantec AntiVirus/Filtering and Optus Software's FACSys Fax Connector 2000. The FACSys Fax Connector 2000 service acted as an interface between the FACSys fax server and the Exchange 2000 server, letting us send and receive faxes in Outlook.

I decided to reboot the server with these services stopped so that I could eliminate them as the cause of the problem. After the reboot, the DS Server registry entry didn't appear and I received no errors when I generated the OAB and ran the Mailbox Manager. I restarted Symantec AntiVirus/Filtering and kept an eye on the registry and event log. Again, I was able to generate the OAB and run the Mailbox Manager with no errors. Finally, I restarted FACSys Fax Connector 2000. The registry entry appeared, I couldn't generate the OAB, and the Mailbox Manager failed with errors 9175 and 9200. These errors also appeared in Event Viewer. I realized that the cause of the registry entry reappearance was the FACSys Fax Connector 2000 service.

I decided the Mailbox Manager process must be failing because its Messaging API (MAPI) profiles were deleted from the registry. I checked the Exchange 2000 server's HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles registry subkey and found seven ExchangeAdmin profiles, all with a different number after the name. I saved all the profiles, then deleted them. I hoped the correct registry entries would appear and that the Mailbox Manager would run after Exchange 2000's System Attendant restarted. After I restarted the Exchange 2000 server, everything worked as I expected.