If you use MBSA 1.2 then you need to upgrade to MBSA 2.0. Here's why: According to Microsoft's MBSA Web page, "The MBSA 1.2.1 tool reaches its end of life on March 31, 2006. After this date, MBSA 1.2.1 will no longer be supported and the MSSecure.XML file automatically downloaded by MBSA 1.2 will no longer be updated to include new security bulletins. We encourage you to migrate to MBSA 2.0 before March 31, 2006, to ensure continued security bulletin detection."

So there you have it. You better upgrade soon!