Microsoft will release 4 critical, 1 important, and 1 moderate security bulletins on June 12. Here's the lowdown on what software you're going to need to patch:

Windows 2000, XP, Server 2003, Vista, Internet Explorer 5.x, 6.x, and 7.0, Outlook Express, Windows Mail, Visio 2002, and Visio 2003.

Sounds to me like nearly everybody who uses Microsoft software is going to be busy next week patching. You can get a few more details in Microsoft Security Bulletin Advance Notification for June 2007.