Reported December 14, 2004, by Microsoft

VERSIONS AFFECTED

·         Microsoft Windows NT Server 4.0 Service Pack 6a

·         Microsoft Windows NT Server 4.0 Terminal Server Edition Service Pack 6

·         Microsoft Windows 2000 Service Pack 3 and Microsoft Windows 2000 Service Pack 4

·         Microsoft Windows XP Service Pack 1

·         Microsoft Windows Server 2003

·         Microsoft Windows XP 64-Bit Edition Service Pack 1

·         Microsoft Windows 98, Microsoft Windows 98 Second Edition (SE), and Microsoft Windows Millennium Edition (Me)

DESCRIPTION
Two vulnerabilities exist in Microsoft WordPad, both of which could result in the execution of arbitrary code on the vulnerable system. The problem exists when a specially crafted file is opened by WordPad or another application that utilizes the vulnerable library and results in a buffer overflow.

VENDOR RESPONSE
Microsoft has released Security Bulletin MS04-041, "Vulnerability in WordPad Could Allow Code Execution (885836)," to address these vulnerabilities and recommends that affected users immediately apply the appropriate patch listed in the bulletin.

CREDIT
Discovered by Greg Jones and Lord Yup.