I want to run VBScript administrative scripts on my Windows NT 4.0 production servers. According to Microsoft, one requirement for installing Windows Script Host (WSH) is that you install Microsoft Internet Explorer (IE). However, a best practice for production servers is to install only software that's absolutely necessary. After some investigation, I discovered that IE 5.5, which includes WSH 5.5, has three DLLs (advpack.dll, shlwapi.dll, and urlmon.dll) that aren't in the standalone version of WSH 5.5. I considered copying these DLLs from an IE 5.5 installation, installing them on a server, then installing WSH 5.5. However, I ran across a Microsoft statement that said copying those .dll files without installing IE is against the end-user license requirements because IE gives you the license to have and use those .dll files. Is installing WSH without IE technically and legally possible, or is IE a true requirement?

WSH depends on two DLLs—shlwapi.dll and urlmon.dll—to work. These DLLs are in IE but not the standalone versions of WSH that are available from the Microsoft Windows Script Technologies Web site (http://msdn.microsoft.com/scripting). The DLL dependency is due, in large part, to WSH's design and evolution. WSH evolved from the same ActiveX script host design and architecture originally developed for Microsoft IIS and IE. When Microsoft decided to expose ActiveX scripting to the Windows OS (i.e., decided to create WSH), Microsoft reused the functionality in IE rather than recreating redundant functionality. Although Microsoft could have repackaged and shipped the DLLs with WSH, that's not the direction that it took.

Today, Microsoft integrates IE in all the Windows OSs. The OSs use IE for a variety of tasks, including HTML-based documentation and Help files. As a result, browsers are becoming increasingly more commonplace across enterprise platforms. I understand your concern with installing IE on production servers and agree with your software installation practices. However, if you want to run WSH scripts on your NT 4.0 servers, you need to install IE. Sorry I don't have better news.