Now that you're getting comfortable running Windows 2000 Professional, it's time to start thinking about your upgrade path to Windows XP. Windows XP Beta 2 looks pretty solid, which leads me to think the OS will make its midyear launch window. And a new OS means it's time to start worrying about which applications won't work.

Microsoft is well aware of the application-compatibility problem, especially because Windows XP targets the Windows 9x code base users. With the beta installation, a shortcut that launches the Start Applications in Compatibility Mode Wizard is right on the desktop. The wizard will help applications that expect and check for specific versions of the OS (Win2K, Windows NT 4.0, and Windows 9x) run under Windows XP. Of course, you'll likely have to update all of your system utility programs, (e.g., antivirus software, backup software, disk management tools) for Windows XP, so that's a basic set of upgrades you need to plan and budget for.

What surprises me about Beta 2 are the number of deal-breakers that prevent Windows XP Beta 2 from installing. Using Beta 1 on a no-name system didn't present me with any problems. On generic hardware, with no odd or unusual devices installed, Whistler Beta 1 ran as well as could be expected. With Beta 2, I decided to branch out a little. I first upgraded a Compaq Armada notebook that was running an intermediate build of Whistler. That upgrade went smoothly, and other than the build number changing on the desktop display, there weren't any obvious issues. Next, I did a clean install on the desktop system that was running Beta 1 and had no problems there, either. Then I tried to upgrade several notebook computers I have in the office. All these systems gave me a list of applications and devices that couldn't be upgraded and a message to fix the problem before continuing. Then the install just exited, without giving me the option of installing anyway (which Win2K did when it encountered similar problems during installation). I remember losing functionality from things such as Dell system management software when upgrading computers from NT 4.0 to Win2K, so I wasn't surprised to see the same warnings from Windows XP. I was, however, a little surprised that I couldn't simply acknowledge that certain applications and drivers need to be disabled and continue with the installation.

This is, of course, beta software, and I'm sure that Microsoft will eventually deal with the various drivers and applications that don't support an upgrade to Windows XP, especially when vendors release XP SKUs of their complete product lines. If you're dealing with older hardware, and plan to move to XP, now's the time to sign up for the Windows XP Preview program.

One last note for this week: Every time Microsoft introduces a new OS, you always seem to need more memory. If you plan to upgrade any Win9x systems to XP, and you have less than 128MB of RAM in those systems, I suggest you make a quick memory purchase. With the street price of 128MB DIMMs in the $40 range right now, it's a cheap investment that will make the user experience significantly better. And if you're running Win2K with less than 128MB of RAM, what are you waiting for?