The first release was met with huge approval, and now version 2.0 builds on the original release's success.

Developed by Daniel Ratliff, PowerShell OSD Frontend helps eliminate the majority of the backend tasks for configuring and then deploying operating systems by giving the process a friendly face. Powering the entire solution is a set of PowerShell scripts.

Here's what it does:

  • Prompts for authentication to your domain
  • Displays basic computer information such as Make, Model, NIC, etc.
  • Prompts for computer name, with a few samples listed
  • Default computer name is WK and the machines serial number
  • For VMWare virtual machines, computer name is VM and the authenticated user
  • Scans your site server for existing device records
  • Utility to format disk
  • Utility to delete ConfigMgr records
  • Utility to specify source computer for data migration

Features added in version 2.0:

  • New tabbed display
  • Tooltips
  • Customizable logo and icon (just replace OSDLogo.png and Powershell.ico)
  • Management of ConfigMgr unknown computer records, delete records, search for records, and show task sequence deployments (my personal favorite, showing the list of deployments before you click continue is a major time-saver. Until the product team hopefully adds that functionality.)
  • Bullet list as needed
  • Drop down to choose timezone
  • Migration support
    • Specify computer name to migrate from (can be used for side by side migration, application mapping, etc)
    • Specify user name to migrate from (can be used for side by side migration, User-Device affinity, etc)
    • Specify user to add to local admin
  • Button to quickly open smsts.log with CMTrace (a favorite among our techs)
  • Stand-alone media support (not sure why these two cause the Frontend to freeze for SA media, but they do)
    • AD prompt to authenticate is skipped
    • Confirmation prompt is skipped
  • Button to restart the computer
  • Confirmation prompt after clicking continue

  

Requirements:

  • WinPE 4.0+
  • PowerShell 3.0+
  • .NET Framework 4.0+

Read more about it and grab the download: PowerShell OSD Frontend 2.0!