Testing X2 and K56 connectivity in lieu of ISDN

If you've followed this column for the past couple of months, you know I've been on a quest to establish a high-speed connection between the small office/home office (SOHO) lab in my basement and the Windows NT Magazine Lab. I wish I could start this column by saying that my SOHO lab now has a functional ISDN line. I can't. Since I began my quest for ISDN 4 months ago, US West field representatives have stood me up four times, and I have logged countless phone calls to the company. For all my effort, I don't think my SOHO lab is any closer to ISDN connectivity than it was when I began this process. I've moved beyond anger and frustration. Now I just feel numb. US West has worn me down.

Like Nature, I Abhor a Vacuum
Despite the trouble with US West, I still longed for high-speed access. Therefore, I used the endless ISDN delay as an opportunity to take 56 kilobits per second (Kbps) technology for a test ride. I set up a U.S. Robotics/3Com I-modem in the Lab to support incoming X2 calls. At the same time, my local Internet Service Provider (ISP) implemented K56 technology. Thus, I had two chances (in theory, at least) to test 56Kbps connections. I figured if I couldn't get ISDN speeds, I could at least beat the connections my 28.8Kbps modem offers.

Lab Mice

Both X2 and K56 use connections that are analog on one end and digital (such as ISDN or fractional T1) on the other end. Both technologies offer speeds of 56Kbps on transmissions from the digital side to the analog side; transmissions from analog to digital do not exceed V.34 speeds (33.6Kbps). All things considered, I found X2 and K56 connections to be attractive short-term alternatives to ISDN.

I began my experiment by trying to establish a K56 connection to my ISP. I attached a Motorola ModemSURFR to one of my SOHO systems, configured the modem software, dialed the digital line for my ISP, and achieved a data transfer rate of 28.8Kbps. My heart sank. I dialed in repeatedly and managed to connect at 31.2Kbps most of the time, but that's a far cry from 56Kbps. I realized that achieving a K56 connection wasn't going to be easy.

Because the ModemSURFR has no external status indicators, I had difficulty diagnosing why I couldn't get a faster connection. I had no idea what the ModemSURFR did to negotiate a connection speed when my ISP's server answered the phone. However, when I read the ModemSURFR documentation's fine print, I learned that the unit supports the K56Plus standard. My ISP supports the K56Flex standard.

I asked my ISP about the difference between K56Flex and K56Plus technology. The support representative said, "All I know is that they are not 100 percent interoperable." I didn't know whether my disappointing connection rates resulted from a conflict between the two standards, so I bought a Zoom 56K modem, which supports K56Flex. I chose the Zoom 56K because it has external status lights that let me watch the modem negotiate connections.

Back in my SOHO lab, I replaced the ModemSURFR with the Zoom modem. After installing the Zoom software, I dialed in to my ISP's server. I watched the modem's lights as the unit connected to my ISP's machine. The K56 light turned on, indicating that the modem was negotiating a 56Kbps connection. Then the K56 light turned off, and the V.34 light came on. The Zoom 56K connected at 31.2Kbps. Although I tried repeatedly, I could not get a higher rate.

I called my ISP again and talked with someone who had some technical knowledge. This representative admitted that very few customer connections are faster than V.34. He said one customer had managed to achieve 45Kbps connections to a neighboring site, but that such speeds were the exception, not the rule. He told me that I can't achieve a better connection rate because I am 10 miles away from the ISP and the city's telephone infrastructure is extremely old. I asked him, "So why did you implement K56 technology?" His answer: "It's a marketing thing, really." That comment ended my enthusiasm for pursuing a K56 connection to my ISP.

X Marks the Spot
After giving up on the K56 connection, I focused on establishing an X2 connection to the Lab. This idea seemed more promising for several reasons. First, my SOHO lab is less than a mile from the Lab, which minimizes the number of phone system relays and switches in the connection. Second, I have complete control of the equipment on both ends of the connection. Third, the equipment on both ends of the connection is from the same vendor. (I used a U.S. Robotics/3Com v.Everything modem to dial in to the Lab's I-modem.)

All these factors must have worked in my favor, because when I dialed in to the Lab from my SOHO lab, I achieved a connection rate of 41Kbps. Although this connection was not 56Kbps, 41Kbps surpassed the rates I got during my K56 experiment. Fueled by this success, I dialed in again and again. The fastest connection rate I reached during this process was 48Kbps. The slowest connection rate was 28.8Kbps, and I averaged 44Kbps. For the first time in months, I felt encouraged. I was making progress.

Because the connection was going so well, I tried another modem. I installed a 3Com Megahertz PC Card Modem, which supports the X2 standard, in my SOHO lab. I dialed in to the Lab and connected at 31.2Kbps. I know that connection speeds can change from call to call, so I dialed in repeatedly. The best I could do was 31.2Kbps.

I could not believe that switching modems made a difference in connection speeds of more than 10Mbps, because both of my modems came from 3Com. I looked for other differences between the two modems' connections, and I realized that I had used different phone lines for the two tests. I transferred the PC Card modem to the phone line I had used with the v.Everything modem and--much to my surprise--I got a 44Kbps connection. To confirm that the phone line was the problem, I used the v.Everything modem on the second phone line to dial in. My connection speed did not exceed 31.2Kbps.

I am usually not surprised when different phone lines behave differently, but US West installed the wiring for these two lines at the same time. The only difference between the lines is that I activated the second line 6 months after I activated the first line. Obviously, the second line goes through different switches than the first.

To be sure that the difference in the lines had not caused my K56 problems, I tried to connect to my ISP using my K56 modems on both lines. My K56 connections topped out at 31.2Kbps, no matter which phone line I used. I concluded that the distance between my SOHO lab and my ISP ruined my chances for a good K56 connection.

Don't Jump to Conclusions
I don't think that my recent experiences demonstrate that X2 is better than K56 technology. Such a conclusion is unfair. X2 worked well in my tests because of my SOHO lab's proximity to the Lab, not X2's technological superiority. I'm willing to bet that in the reverse situation (i.e., I had put K56 equipment in the Lab and my ISP had implemented X2) K56 would have worked and X2 would have failed. I view X2 and K56 as equally bad technologies.

My 56Kbps testing taught me a valuable lesson: Don't count on this technology to work in most circumstances. Because of the poor state of US telephone systems, achieving 56Kbps connections is difficult. I can't be sure, but I suspect that other countries' phone systems provide better 56Kbps access. My Canadian friends have no problem getting 56Kbps connections.

Because of the lackluster results of my testing of 56Kbps technologies, I still want my ISDN line activated. So, I have a message for US West: Don't bother calling ahead. Just drop by anytime.