A customer asked me to install Internet Explorer (IE) 4.0 Service Pack 2 (SP2) on the company's Windows NT Server 4.0, Terminal Services Edition (TSE) machine with MetaFrame 1.8 to be Y2K compliant. After a standard installation, I restarted the system and logged back on as an administrator. While starting, the system stopped responding and, except for the Start menu and the Task Manager, no desktop appeared. On client machines, I saw limited desktops with the error message, "Cannot access this file. Path is too long." When I responded to the error messages by choosing OK, the client sessions disappeared. I tried to uninstall MetaFrame and do a repair install on TSE. When I restarted the machine, none of my published applications functioned and their filenames had a read-only No symbol overlaying them. What's going on here?

You have two problems that are easy to fix. First, don't install Active Desktop on a TSE server. Active Desktop caused your desktops to disappear. You should remove IE and reinstall it without the Active Desktop component (Microsoft doesn't recommend uninstalling just the Active Desktop component because doing so will fix the server problem only, not the client problem). For IE 4.01 installed with Active Desktop,

  1. Open the Control Panel. (Note: It might take a long time for Control
    Panel to open after you click it.)
  2. Double-click Add/Remove Programs.
  3. Select Microsoft Internet Explorer 4.0, and click Add/Remove.
  4. Remove IE and its components.
  5. Reinstall IE 4.0 without the Active Desktop component

Second, you experienced a problem with your published applications because your Registry entries for published applications disappeared. You need to delete the remnants of the old published applications names and recreate the published applications. The three Registry entries for published applications are:

  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\ManagedApplications. This key typically contains the application definitions, but yours should be empty at this point. You're seeing the read-only symbols because these parameters are missing. If you see any entries in this key, you can delete them.
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ICABrowser\Parameters\AppName. This key sets the names for any applications you create under a domain scope for compatibility for older versions of WinFrame or MetaFrame with published applications in the same domain. You should delete any entries in this key.
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ICABrowser\Parameters\ManagedAppNames. This key sets the name for any applications you create under a 1.8 Application Farm scope with published applications. You should delete any entries in this key as well.

Close all versions of Published Application Manager and stop the ICA Browser service. Delete the Registry entries I mentioned, and restart the ICA Browser service. You don't need to restart the server itself. When you open the Published Application Manager, you shouldn't see any entries. You can recreate your old entries, and everything should return to normal. Have fun and be careful.