Q. What versions of Hyper-V are supported to run Windows Server 2016 VMs?

A. To run Windows Server 2016 VMs the Hyper-V host should be at least Windows Server 2012 R2. The standard support statement is Microsoft supports running an OS on the n-1 version of the hypervisor, i.e. for Windows Server 2016 that means Windows Server 2012 R2 Hyper-V. Some older versions may work however I have also seen the OS actually blue screen when trying to start on too older hypervisor version.