Fixing the Red Screen-after-update issue with the Microsoft Surface

RSS

After some issues during the update, like booting straight into the UEFI screen a couple times (which was strange), the Surface Pro finally seemed to be working. Well, except for Surface-branded boot screen being red now, instead of the standard white-on-black standard. This was my remaining issue.

A System Update was made available while I was at MMS 2013.  The previous System Updates had applied successfully, lulling me into a false sense of security, so I applied the update while in my hotel room.  The latest System Update turned out to be the worst so far, and probably the scariest update of all since I was relying on the Surface as my primary traveling device.  After some issues during the update, like booting straight into the UEFI screen a couple times (which was strange), the Surface Pro finally seemed to be working.  Well, except for Surface-branded boot screen being red now, instead of the standard white-on-black standard.  This was my remaining issue.

After going back and forth about it with the Surface folks on Twitter (who are great at monitoring and replying, btw), they suggested I hit the Surface forums.  I did that to find that I was not alone.  The Red Screen boot was affecting a lot of people.  To find out, the Secure Boot keys had been deleted during the update, and the Red Screen was supposed to be a “warning” screen to identify that there were missing Secure Boot keys.  A Red Screen warning is nice, but with no additional message, it’s worthless.  And, who knew about Microsoft including a warning screen to indicated “something” was wrong? Everything else about the Surface worked fine, except for the annoying Red boot screen, so fixing the issue wasn’t critical at the time, but when I returned home from MMS 2013 I started digging into it.

After a bit of messing around, I was able to get back into the UEFI screen and choose to reinstall the Secure Boot keys, which eliminated the Red Screen for good.  In some cases, I had seen reports of Microsoft suggesting a return to a Microsoft Store to have the unit replaced.  But, there’s a true fix.  Here’s how I did it:

  1. With the Surface powered off, I pressed and held the Volume Up button.
  2. Then I powered the Surface on, holding the Volume Up button pressed the entire time.
  3. Once the Surface entered into the UEFI interface, I chose “Install Default Secure Boot Keys” and selected “Yes” to cause the Surface to load the default secure variables.
  4. Next, I made sure that the “Secure Boot” option was enabled, exited setup, choosing “Yes” to save the configuration changes.

With the Secure Boot keys reinstalled, the Surface boots normally with the boot screen no longer displaying Red.

Please or Register to post comments.

What's Limited Genius?

The difference between stupidity and genius is that genius has its limits - Einstein

Contributors

Rod Trent

Rod Trent is the IT Community Manager for Windows IT Pro. He is a leading expert on Microsoft System Center technologies and has more than 25 years of IT experience, with over 20 years dedicated to...
Blog Archive

Sponsored Introduction Continue on to (or wait seconds) ×